Georgia Firearm Forums - Georgia Packing banner

1 - 3 of 3 Posts

·
Registered
Joined
·
383 Posts
Discussion Starter · #1 ·
So several months ago I bought 3 C Products mags for my 5.45 Ar. When I got the mags and loaded them the first three rounds will feed, fire, and eject properly but after that one of two things happens.

A) The follower in the magazine tilts forward allowing all the rounds to shift forward in the mag or B) the BCG fails to strip the next round and the bolt travels forward (all the way to lock) with out a round in place. When this occurs I can cycle it by hand and its about 50/50 on whether or not it picks up the next round.

I assumed it may be a spring issue so I have replaced all three of the springs with quality braided wire springs and I am still having the same issue. Now before someone asks...Yes they are mags designed and built for the 5.45 round VS the 5.56 both the mag followers and the metal base plates say 5.45. Also, The gun shoots great from the three existing C Products mags that I bought with the gun.

Any Ideas?
 

·
Registered
Joined
·
477 Posts
Take out the follower and look for any rough edges on the sides that would rub the magazine body. I've had a few magpul followers that I've needed to slightly trim/sand down to keep from catching.

If you can't get them to work, call CProducts. They work hard to make sure your mags work.
 

·
Registered
Joined
·
383 Posts
Discussion Starter · #3 ·
madcapmagician said:
Take out the follower and look for any rough edges on the sides that would rub the magazine body. I've had a few magpul followers that I've needed to slightly trim/sand down to keep from catching.

If you can't get them to work, call CProducts. They work hard to make sure your mags work.
I checked them over and they all look great! Looks like I'll just have to suck it up and give them a call.

Thanks for the advice.
 
1 - 3 of 3 Posts
Top